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Introducing iniExpert
Welcome to iniExpert -- a powerful Windows utility that allows you to examine and modify 
your Windows environment.    iniExpert is designed to make editing Windows initialization 
files easy.    iniExpert provides detailed information right where you need it - on screen.    
Each entry is clearly explained, including the entry's purpose, setting range and default value.

Many of the settings that are stored in initialization files are accessible from a dialog box in 
Control Panel or from a menu or dialog box in an application.    However, there are many 
occasions where you will need to manually edit the initialization files.    Some entries 
(especially entries in the SYSTEM.INI file that are used to help Windows communicate with 
your hardware) simply have no user interface available to change them.    Many times, when 
you install a new program or call technical support for a program, you will need to add or 
change an initialization file entry to make the program run.

iniExpert takes the mystery out of manually editing initialization files.    When you load an 
initialization file in iniExpert you are presented with a list of sections so that finding the 
section you want is easy.    iniExpert provides on-screen definitions for all of the standard 
Windows entries and entries for many Windows applications, so when you have to manually 
edit an initialization file you are well informed of what you are changing and why.    iniExpert
tells you what the entry controls, what the possible settings are, and what the default setting 
is.    Blindly changing initialization file entries without this information can cause 
unpredictable results, including "locking-up" your system.

iniExpert may be used to "walk through" your initialization files.    You can read the 
description iniExpert provides and use the information to learn more about Windows or to 
fine tune your system for optimum performance.



Starting & Stopping iniExpert
You can start iniExpert from the Program Manager window when you run Windows:

1. Display the Program Manager window.
2. If necessary, select the iniExpert group window.
3. Double-click the iniExpert icon.

To stop iniExpert:

1. Select the Exit button from the main screen. 
or
press (ALT+X)
or

2. Select the Exit command from the File Menu. (ALT+F, X)
or

3. Select Close from or double-click the System Menu. (ALT_F4)

If the currently open initialization file has changed, you will be prompted to save 
changes.    If the Automatic File Save option is enabled the file will be saved without 
prompting.



How do I?

Create a new initialization file
Open an initialization file
Save an initialization file
Save an initialization file to a new file name
Print an initialization file
Add an entry to an initialization file
Change an entry in an initialization file
Delete an entry from an initialization file
Delete an entire section from an initialization file
Comment out an Entry
Uncomment an Entry
Adjust Program Options



Opening an initialization file
There are three ways to open an initialization file:

To open a file using the Open dialog box:
1. Select File Open from the iniExpert menu. (ALT+F, O)
2. The Open dialog box will appear allowing you to select the file name.

To open a file using the File Name field:
1. Type the name of the file you wish to edit in the File Name field.
2. If the file is not in the Windows directory or on the path you will have to type a 

fully qualified path name for the file.

To easily open a file that you have opened in the past:
1. Select the file from the drop down file list in the File Name combo box.



Saving an initialization file
To save an initialization file:

1. Select File Save from the iniExpert menu. (ALT+F, S)
or
Use the keyboard accelerator for saving files. (CTRL+S)

Note: The save command will not be available if the initialization file has not been changed.
Note: If you attempt to open another file or exit the program and the initialization file has 

changed, a message box will appear asking you if you want to save the changes to the 
file.

See Also
Automatic File Saving



Save an initialization file to a new file name
To save an initialization file to a new file name:

1. Select File Save As from the iniExpert menu. (ALT+F, A)
2. Enter the new name for the file in the Save As dialog box.



Create a new initialization file
To create a new initialization file:

1. Type the name of the initialization file in the File Name dialog box.
2. Add entries to the initialization file.
3. Save the initialization file.



Open Dialog Box
Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

To select a file name with the Open dialog box:
1. Select the drive letter the file is located on with the Drives combo box.
2. Select the directory the file is located in with the Directory list box.
3. If the initialization file has an extension other than .ini, select All Files in the List 

Files of Type combo box.
4. Select the file from the File Name list box or type the file name in the File Name 

edit filed.
5. Select OK to accept the file or Cancel to cancel the open operation.



Adding an entry to an initialization file
To add a new entry into an initialization file:

1. Open the initialization file you wish to add the entry to.
or
Create a new initialization file to add the entry to.

2. Select the section you want to add the entry to from the Section combo box drop 
down list.    If the section is a new section enter the section name in the Section 
field.

3. Enter the name of the entry in the Tag field.
4. Enter the value to assign the entry in the Value field.

5. Click the add button 
or
press (ALT+A) 
or
select the Add command from the Edit Menu (ALT+E, A)
to add the entry.



Changing an entry in an initialization file
To change an existing in an initialization file:

1. Open the initialization file you wish to change the entry in.
2. Select the section you want to change the entry in from the Section combo box 

drop down list.
3. Select the entry you want to change from the Entry list box.
4. Enter the value to assign the entry in the Value field.

5. Click the change button 
or
press ALT+C
or
select the Change command from the Edit Menu (ALT+E,C)
to change the entry.



Deleting an entry from an initialization file
To delete an existing entry from an initialization file:

1. Open the initialization file you wish to delete the entry from.
2. Select the section you want to delete the entry from in the Section combo box 

drop down list.
3. Select the entry you want to delete from the Entry list box.

4. Click the delete button 
or
press ALT+D
or
select the Delete command from the Edit Menu (ALT+E,D)
to delete the entry.



Adjusting Program Options
Most program options are adjusted by choosing the Preferences command from the Options 
Menu. (ALT+O,P)    The Preferences command displays the preferences dialog box.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

See Also:
Entry Help



Finding Entries in initialization files
Use the Find Entry command from the Edit Menu to search the current initialization file for a 
specific entry. (ALT+E, F)(CTRL+F)    The Find Entry command displays the Find dialog box.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

See Also
Find Entry Again



When the Entry Help is enabled, a text window will appear at the bottom of the main window, 
displaying help for common initialization file entries.    If the entry is not in the help database, 
but the section is, the text window will display help for the section.    The value combo box drop 
down list will also be filled with value choices where possible.



Displaying program copyright and version information
To display program copyright and version information choose the About command from the 
Help Menu. (ALT+H,A)



Printing an initialization file
To print an initialization file choose the Print command from the File Menu. (ALT+F,P)
(CTRL+SHIFT+F12)    The print command brings up the print dialog box.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.



Setting print options
To select a printer or set print options choose the Print Setup command from the File Menu. 
(ALT+F,R)    The Print Setup command displays the Print Setup dialog box.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.



Displaying the on-line help contents page
To display the on-line help contents page choose the Contents command from the Help Menu 

(ALT+H,C)(F1), or by clicking on the Help Button.     From the contents screen, 
you can jump to step-by-step instructions for using iniExpert and various types of reference 
information.

Once you open Help, you can click the Contents button whenever you want to return to the 
contents page.



Save As Dialog Box
Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

To select a file name with the Save As dialog box:
1. Select the drive letter the file is located on with the Drives combo box.
2. Select the directory the file is located in with the Directory list box.
4. Select the file from the File Name list box or type the file name in the File Name 

edit filed.
5. Select OK to accept the file or Cancel to cancel the save operation.

Note:    If the file already exists, you will be prompted whether or not you wish to overwrite the 
existing file.



Choosing custom colors
iniExpert uses different colors to display different types of entries in the Entry list box.    The 
foreground and background colors for both the highlighted and normal states can be set for each 
of the following entry types:

1. Normal Entries - Default: Black
2. Comment Entries - Default: Dark Cyan
3. Missing Entries - Default: Dark Gray

To customize the colors:
1. Choose the Preferences command from the Option Menu. (ALT+O,P)
2. Select the item you wish to customize from the Color combo box.
3. Choose the Select Color button. (ALT+S)

The Color dialog box will appear.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

The Define Custom Colors button expands the dialog box to include a color picker. (ALT+D)





iniExpert Main Window
Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.



The Automatic File Save option allow you to turn off prompting for file saves.    When the 
Automatic File Save option is checked iniExpert will save the current initialization file whenever
you close it or exit the program.    The Automatic File Save option is accessible from the 
Preferences dialog box.

Note:    Automatic file saving can be very dangerous if you inadvertently change your 
initialization file.    The Automatic File Save option should only be used with the Create Backup 
option.



The Create Backups option allow you backup your initialization files.    When the Create 
Backups option is checked iniExpert will create a backup copy of the initialization file 
(filename.bak) whenever you save.    The Create Backups option is accessible from the 
Preferences dialog box.



Status Bar
The status bar displays help information.    As you move through the menus the status bar will 
display help information on the menuitem.



iniSave
The iniSave program provides a layer of protection for your initialization files.    Each time you 
execute the iniSave program makes a backup copy of your initialization files.    If the iniSave 
program is placed in your startup group, the initialization files will be backed up when you 
successfully start Windows.    This allows you to restore your last good set of initialization files 
should Windows refuse to start.

Files

To specify which files iniSave backs up, use Notepad to edit the file INISAVE.DAT located in 
the directory where you installed iniExpert.    The INISAVE.DAT file contains a list (one 
filename per line) of the initialization files to be backed up.    The default INISAVE.DAT 
contains entries for the WIN.INI and SYSTEM.INI.

Restoring initialization files

To restore the last set of initialization files    backed up by iniSave, change directories to the 
directory where you installed iniExpert and run the FIXINI.BAT file.





Menus
Hint: To get help on an individual menu item, click on the item in the menus below or press tab 
until the item is highlighted and then press enter.

The File menu allows you to open, close, save, and print    initialization files as well as exit the 
program, restart, and reboot:

The Edit menu allows you to find entries in or change the initialization file:

The Options menu allows you to modify program options:

The Help menu allows you to access this help file and get program and copyright information:



Searching for a Help Topic
You can find information quickly by using the Search command in the Help menu. The Search 
command opens the Search dialog box, where you select a word that you want to search for. All 
help topics associated with that word are listed, and you can select one to view. For example, to 
find out how to save a file, you could select "save" from the list. Topics that have the word 
"save" associated with them would then be listed in the Search dialog box. 

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.



Turning Entry Help on or off
Use the Entry Help command from the Options Menu to display and hide Entry Help. (ALT+O, 
E)    A check mark appears next to the menu item when the Entry Help is displayed.



Repeating the Last Find
Use the Find Entry Again command from the Edit Menu to repeat the last find command. 
(ALT+E, A)(F3)

See Also
Find Entry



Restarting Windows
Use the Restart Windows command from the File Menu to exit and restart the Windows system. 
(ALT+F, W)(CTRL+W)    iniExpert informs Windows whenever it changes the win.ini file, 
however some changes will require you to exit Windows and restart for the changes to take 
effect.    You can use the Restart Windows Command when you make changes and wish them to 
take effect immediately.

Note: A message box will appear asking you if you really wan to restart Windows.

See Also
Reboot



Rebooting the System
Use the Reboot command from the File Menu to perform a "warm" boot of the system. (ALT+F, 
B)    In rare situations it may be necessary to reboot the system for changes to take effect.

Note: A message box will appear asking you if you really wan to reboot the system.

See Also
Restart Windows



Deleting an entire section from an initialization file
To delete an entire section from an initialization file:

1. Open the initialization file you wish to delete the section from.
2. Select the section you want to delete in the Section combo box drop down list.
3. Select the Delete Section command from the Edit Menu (ALT+E,S) to delete the 

section.

Note: A message box will appear asking you if you really wan to delete the section.



Commenting out an entry
Use the Comment Line command from the Edit Menu to comment out the selected entry. 
(ALT+E, M)    Commenting out an entry renders that entry ineffective.    In other words you will 
still be able to see the entry, but Windows will ignore it.    Commented entries appear in a 
different color in the Entry list.

See Also
Uncommenting an Entry



Uncommenting an entry
Use the Uncomment Line command from the Edit Menu to uncomment the selected entry. 
(ALT+E, U)    Uncommenting an entry re-activates the entry.

See Also
Commenting out an Entry



Learning how to use Help
To learn how to use Help choose the Using Help command from the Help Menu. (ALT+H,U)



Closing an initialization file
To close and initialization file choose the Close command from the file menu. (ALT+H,U)

Note: If the initialization file has been changed you will be prompted to save the changes.



Displaying context sensitive help

Use the Context Sensitive command from the Help menu to obtain help on a specific portion of 
iniExpert. (ALT+H,X)(SHIFT+F1)    The mouse pointer will change to an arrow and question 
mark.    Then click somewhere in the iniExpert window.    The Help topic will be shown for the 
item you clicked.

Shortcut
Keys: SHIFT+F1





Are you sure you want to restart Windows?
Answer yes to restart windows, no to return to iniExpert.



Are you sure you want to reboot?
Answer yes to reboot, no to return to iniExpert.



Filename does not exist, would you like to create it?
Answer yes to create the new initialization file, no to cancel the operation.



Save changes to Filename?
Answer yes to save the changes to the initialization file, no loose the changes, cancel to cancel 
the operation.



Filename does not exist, would you like to remove it from the 
file list?
Answer yes to remove the initialization file from the filename combo box drop down list, no to 
leave the initialization file in the list.



File copyright information has been illegally modified.    
Aborting.
The file copyright information in iniExpert has been illegally modified.    As a protection 
mechanism, iniExpert will not continue to run.    If you get this message please report it to 
Chattahoochee Software.



Filename is not a valid initialization file.
The initialization file you have attempted to load is not a valid initialization file.    The most 
common cause for this error is an attempt to load a file that does not start with a section heading 
([section]).



Internal application error.
An internal failure has occurred in the application.    Please report to technical support.



Please enter an integer.
The text you entered into the dialog control was not an integer.



Please enter a number.
The text you entered into the dialog control was not a number.



Please enter an integer between number low and number high.
The number you entered is too large or too small. 



Please enter a number between number low and number high.
The number you entered is too large or too small.



Please enter no more than number characters.
The string you entered was too long.



Destination disk drive is full.
The drive you attempted to save to is full.    Please clear up some space or try an alternate drive.



Unable to read from filename, it is opened by someone else.
The file you tried to open is in use by another application.    Please close the file in the other 
application.



Unable to write to filename, it is read-only or opened by 
someone else.
The file you tried to save could not be accessed because it is in use by another application or 
because it is read only.



An unexpected error occurred while reading filename.
An error occurred while trying to read the file.    The file may be corrupted.



An unexpected error occurred while writing filename.
An error occurred while trying to write the file.    The file may be corrupted.



Not enough memory for operation.
The operation you requested required more memory than is available.





Buttons
The buttons iniExpert's main window provide a quick method or performing common actions.

Hint: To get help on an individual button, click on the button below or press tab until the button 
is highlighted and then press enter.





Title Bar

The title bar is located along the top of a window.    It contains the name of the application and 
document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their
title bars.

The title bar contains the following elements:
Application Control-menu button
Minimize button
Name of the application
Name of the document



Minimize Button

The minimize button it located at the upper right hand corner of the window.    Pressing the 
minimize button reduces the iniExpert window to an icon.



Size command (System Menu)
The size command is used to changes the dimensions of the active window.    The iniExpert main
window is not resizeable.



Move command (System Menu)
Use this command to display a four-headed arrow so you can move the active window or dialog 
box with the arrow keys.

Shortcut
Keys: CTRL+F7
Mouse: Drag the title bar of the window.



Minimize Command (System Menu)
Use this command to reduce the iniExpert window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

This command is used this command to enlarge the active window to fill the available space.    
The iniExpert main window cannot be maximized.



Close Command (System Menu)
Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the iniExpert window or dialog box



Restore Command (System Menu)
Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (System Menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or 
close an application on the list.

Hint: To get help on an individual dialog control, click on the item in the menus below or press 
tab until the item it highlighted and then press enter.

Shortcut
Keys: CTRL+ESC





The Directories list box (ALT+D) allows you to select the directory that contains the file you 
wish to pick.



The Help button (ALT+H) displays the on-line help for the dialog box.



The Drives combo box (ALT+V) allows you to select the drive that contains the file you wish to 
pick.



The Network button invokes the Windows for Workgroups "Connect Network Drive" dialog box.
This button will only appear if you are running Windows for Workgroups.



This window displays a short help message about the dialog.



The File Name edit box (ALT+N) serves two purposes.    It displays the currently selected file, as
well as allowing you to type the name of the file you wish to pick.



The File Name list box (ALT+N, TAB) allows you to select the file you wish to pick.



The Cancel button (Esc) cancels the dialog box, making no changes.



The OK button (Enter) accepts the dialog box and all changes made.



The List Files of Type combo box (ALT+T) allows you to select different file types to view in 
the File Name list box.



The Directories text control displays the currently selected directory.



The title bar of the dialog box displays the dialog box title.    Click and drag the title bar to move 
the dialog box.



The system menu of the dialog box contains two commands:
1. Move (ALT+SPACE, M) allows you to move the dialog box with the keyboard.
2. Close (ALT+SPACE, C)(ALT+F4) allows you to close the dialog box.    Close has

the same effect as the Cancel button.



The Colors combo box (ALT+L) allows you to choose the color item you wish to change.    Once
you have chosen the item to change, choose Select Color (ALT+S) to change the color



The Bitmap Buttons check box (ALT+B) allows you to switch between bitmaps or text in the 
buttons of the main window.    If this option is checked, bitmaps will appear, otherwise text will 
appear.



The Select Color button (ALT+S) allows you to change the color of the item selected in the 
Colors combo box (ALT+L).



The Create Backup check box (ALT+C) specifies whether iniExpert will create backup files 
(*.bak) when saving initialization files.    If this option is checked, iniExpert will create backup 
files, otherwise it will not.



The Close button (Enter) closes the dialog box and accepts all changes made.



The Automatic File Save check box (ALT+A) allows you to turn off prompting for file saves.    If
this option is checked iniExpert will save the current initialization file whenever you close it or 
exit the program.

Note:    Automatic file saving can be very dangerous if you inadvertently change your 
initialization file.    The Automatic File Save option should only be used with the Create Backup 
option.



The Match Case check box (ALT+C) allows you to find only those occurrences with the 
combination of uppercase and lowercase letters specified in the Find What edit box.

Note: Since initialization files are not case sensitive, this option is not enabled.



The Match Whole Word Only check box (ALT+W) allows you to find only those occurrences 
that are words by themselves, and not part of a larger word.    Clear this option to find all 
occurrences of the text.



The Find What edit box (ALT+N) allows you to type in the text you want to find.



The Find Next button (ALT+F) finds the next occurrence of the text in the initialization file.



The Direction group allows you to choose whether iniExpert will search forward or backwards 
from the present location to find the keyname.    If the Up radio button (ALT+U) is selected, 
iniExpert will search backwards.    If the Down radio button is selected iniExpert will search 
forward.



The Setup button (ALT+S) allows you to configure or change the printer used to print the 
initialization file.



The Collate Copies check box (ALT+I) specifies whether or not to print multiple copies in order.



The Copies edit box (ALT+C) allows you to specify how many copies of the initialization file 
you wish to print.



The Print Quality combo box (ALT+Q) allows you to adjust the quality of the printout.    In 
general, the higher the print quality, the slower the print.



The Print Range group allows you to choose which portion of the initialization file to print.    
iniExpert supports printing All pages (ALT+A) only.



The Printer text field displays which printer is currently selected to print to.



The Options button (ALT+O) allows you to configure printing options that are specific to the 
selected printer.



The Source combo box (ALT+S) allows you to select which paper bin to print from.



The Size combo box (ALT+Z) allows you to select the size of the paper you are printing on.



The Orientation group allows you to select whether to print in portrait or landscape (sideways) 
mode.    Select Portrait (ALT+R) to print down the long side of the page.    Select Landscape 
(ALT+L) to print down the short side of the page.



The Printer group allows you to select which printer to use.    Select Default Printer (ALT+S) to 
use the printer you have setup to be the default windows printer.    To use a different printer select
Specific Printer (ALT+P) and then choose the printer from the Specific Printer combo box.



The Basic Colors list (ALT+B) contains all of the stock Windows colors.



The Custom Colors list (ALT+C) contains colors you have selected from the color picker.



The Define Custom Colors button (ALT+D) expands the Choose Color dialog box to include a 
color picker.



The Hue and Saturation picker allows you to choose the color you want to add.



The Luminance picker allows you to change the brightness of the colors in the Hue and 
Saturation picker.



The Color|Solid field displays the currently selected color as well as the closest solid color.    Text
will only appear in the closest solid color.



The Hue (ALT+H), Saturation (ALT+S), and Luminance (ALT+L) edit boxes allow you to 
manually enter the color you wish to use.    Hue represents the shade of the color, i.e. Red, 
Purple, Green, etc.    Saturation represents how much of the color is present.    Luminance 
represents how dark or light the colors is.



The Red (ALT+R), Green (ALT+G), and Blue (ALT+U) edit boxes allow you to manually enter 
the color you wish to use.    The values indicate how much red, green, or blue light is used to 
display the color.



The Add to Custom Colors button (ALT+A) allows you to add the currently selected color to the 
Custom Colors list (ALT+C) so that you can select the color.



The Help Text window displays information on the currently selected initialization file entry, if 
available.    If help is not available for the entry help will be displayed for the currently selected 
section, if available.



The Value comb box (ALT+V) allows you to change the value of the entry.    If many cases the 
drop down will contain choices for the value.



The Keyname edit box (ALT+K) allows you to type in the keyname to edit or add a new 
keyname.



The Entry list box (ALT+R) allows you to pick the initialization file entry from the currently 
selected section to add or change.    There are three types of entries:

1. Normal Entries are standard entries that appear in the initialization file.
2. Comment Entries are entries that contain comment text or entries that have been 

de-activated.    These entries appear in Dark Cyan by default.
3. Missing Entries are entries that are not contained in the initialization file but could

be.    These entries appear in Gray by default.



The Section combo box (ALT+S) allows you to enter or choose the section that you want to edit.



The File Name combo box (ALT+N) allows you to enter of choose the file that you want to edit.



The Select a topic list box (ALT+T) displays all of the topics that match the current search 
keyword.



The Go To button (ALT+G) opens the currently selected topic in help.



The Keyword list (ALT+W) allows you to enter or choose the keyword you want to search on.



The Show Topics button (ALT+W) displays all the topics that match the keyword you have 
entered.



The Arrange Icons button (ALT+A) arranges the icons in the lower left hand corner of the 
desktop window.



The Tile button (ALT+T) arranges all of the non-minimized windows so that none of them 
overlap.



The Cascade button (ALT+C) arranges all of the non-minimized windows starting from the 
upper left hand corner.



The End Task button (ALT+E) closes the selected program.



The Switch To button (ALT+E) activates the selected program.



The Task list box lists all of the currently running programs.






